Issues with SafeSend Returns email notifications and Access Code emails
Incident Report for cPaperless, LLC
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 14, 2019 - 08:58 CDT
Investigating
We are currently investigating this issue.
Posted 7 months ago. Mar 14, 2019 - 08:08 CDT
This incident affected: SafeSend Returns v4.0.