SignatureFlow is not available
Incident Report for SafeSend
Resolved
Dear SignatureFlow Clients,

SignatureFlow is back online. We understand that this downtime has been an inconvenience to you and your firm. On behalf of everyone at cPaperless, please accept our sincere apology.

How to Update
Local Installs
- Open SignatureFlow
- Click, “Send for SignatureFlow”
- You will be prompted to update
- Follow onscreen Instructions
- IMPORTANT: Once the update is complete, CLOSE AND REOPEN SignatureFlow. If you don’t, it will repeatedly request you update again.

For Terminal Server/Citrix Environment, please contact our support team at support@cpaperless.com.
Posted Jul 26, 2017 - 07:15 MDT
Update
Unfortunately, SignatureFlow will remain unavailable for some time. We need to update additional components and do not know when an update will be available

Luckily, in the meantime, you can login at https://signatureflow.echosign.com/public/login, with your SignatureFlow credentials, to send documents and manage them online. Please note that anything sent from this account will not show in the SignatureFlow report once it is back online.

We greatly apologize for the inconvenience and are working diligently to get everything back online.
Posted Jun 27, 2017 - 15:31 MDT
Update
The SignatureFlow Application is still not available. It is projected to be back online Tuesday 6/27/2017. We apologize for the delay and inconvenience.
Posted Jun 26, 2017 - 07:29 MDT
Update
The SignatureFlow Application is still not available. It is projected to be back up and running Monday 6/26/2017. We apologize for the inconvenience.
Posted Jun 22, 2017 - 07:31 MDT
Identified
SignatureFlow is currently undergoing maintenance
Posted Jun 20, 2017 - 08:17 MDT