Safesend Returns Offline
Incident Report for SafeSend
Resolved
Thank you for your patience. We rebooted some components and the system is back online.
Posted Oct 13, 2017 - 17:26 MDT
Investigating
The SafeSend returns website is currently not responding or very slow. We are investigating the issue now and will update this page with more information.
Posted Oct 13, 2017 - 17:20 MDT