Intermittent Delays With SafeSend Returns
Incident Report for cPaperless, LLC
Resolved
This incident has been resolved.
Posted over 1 year ago. Jun 26, 2018 - 08:20 CDT
Investigating
We are currently Investigating this issue.
Posted over 1 year ago. Jun 25, 2018 - 15:19 CDT
This incident affected: SafeSend Returns v4.0.