SafeSend Access Links not being created through the Outlook Plugin
Incident Report for SafeSend
Resolved
This issue has been resolved. Access Links Are now being created as they should.

Thank you for your patience.
Posted Feb 13, 2017 - 08:03 MST
Investigating
We are experiencing an issue with the SafeSend plugin at this time. When going through the "Send Link" process, Access Links are not being generated for the email. We are investigating this issue and will update this page when we have more information.

Until we have this resolved, you may send documents through your online account. Please login to our website here https://portal.safesend.com/Login.aspx. We apologize for any inconvenience this may cause.
Posted Feb 13, 2017 - 07:21 MST