SafeSend Portal Account Is under maintenance
Incident Report for SafeSend
Resolved
The two reported issues with the SafeSend Portal have been resolved. Users can now send files without issue and clients are not receiving the below error message when sending through the DropOff.

Please note: Some files sent / received prior to 6/20/17 may have issues being downloaded. This issue will resolve itself over the next 24 – 36 hours
Posted Jun 22, 2017 - 10:20 MDT
Investigating
At this time we are investigating reports surrounding the SafeSend Online Portal. We are investigating the following.

- Transactions failing to send. Users go through compose process but files are not sent
- When sending through the DropOff, senders are getting an error "We're sorry but your transfer was interrupted and did not complete. Please try again."

We are working hard to get these issues resolved. We will update this page with any new information.
Posted Jun 22, 2017 - 09:04 MDT
Identified
Thank you for your patience. The SafeSend Online Portal is now back up and running. The Portal Inbox is loading transactions and no longer stuck.

Some files sent / received prior to 6/20/17 may have issues being downloaded. This issue will resolve itself over the next 24 – 36 hours.
Posted Jun 22, 2017 - 08:27 MDT
Investigating
We are currently investigating an issue with the online portal. Users have reported the "Portal Inbox" is stuck on loading. We will update this page with any new information.
Posted Jun 22, 2017 - 07:25 MDT
Update
Thank you for your patience everyone. At this time, the SafeSend Portal is ready to be used. Any documents sent from this point forward will work without issue. (This is the online portal, not the Outlook Plugin)

There is only one issue that still remains. Some files sent before late afternoon 6/20, may not download. Files sent after should be working fine. This includes DropOff files sent from clients and files sent to your clients from the online portal. Files sent before the stated time are currently being transferred and may take up to a couple days to become available.

If you try to download a file, or try to "Download All" and you get a blank screen, the files will need to be resent or you will need to wait until the file has successfully been transferred. We apologize for the inconvenience.
Posted Jun 21, 2017 - 07:31 MDT
Update
Thank you for your patience. At this time the portal is still being worked on. We are aware that users are still not able to download files from the portal. We are working hard to get this resolved as soon as possible.

We apologize for any inconvenience this may cause.
Posted Jun 20, 2017 - 15:08 MDT
Identified
The online SafeSend Portal is currently under maintenance. We are currently releasing some updated components and it should be fully operational soon.

Thank you for your patience.
Posted Jun 20, 2017 - 12:02 MDT