SafeSend Exchange Expiration Notification Emails
Incident Report for SafeSend
Resolved
This issue has been fixed and the expiration notification service has been turned back on. For any questions or concerns, please contact our Support team at support@safesend.com or 855-818-3552.
Posted May 18, 2022 - 10:22 MDT
Identified
Due to an ongoing issue with expiration notification emails being sent for items already downloaded, we have turned off the expiration notification service. While this will stop inaccurate notifications from being sent, it will also prevent accurate notifications from being sent. We are diligently working to fix this issue and get the notification service turned back on.

We will provide updates as more information is available. For any questions or concerns, please contact our Support team at support@safesend.com or 855-818-3552.
Posted May 12, 2022 - 14:09 MDT
This incident affected: SafeSend Exchange (Legacy Version).