SafeSend Returns Login Issues
Incident Report for SafeSend
Resolved
This incident has been resolved.
Posted Nov 30, 2020 - 17:34 MST
Monitoring
Recent updates to SafeSend Returns caused a small login issue for some customers. Follow these steps for a quick and easy resolution:

1. Close all browser windows and open a new instance
2. Delete any prior safesendreturns.com bookmarks
3. Type www.safesendreturns.com into address bar
4. As preferred, create new bookmark(s)
5. Clear Cache and Cookies (if above steps do not allow user to login)
6. Repeat steps 1-3
7. Contact support@safesend.com if issue persists

For further assistance, please contact the Support team by email at support@safesend.com or call us at 855-818-3552. We appreciate your patience and understanding through this issue.
Posted Nov 30, 2020 - 10:27 MST
This incident affected: SafeSend Returns.