SafeSend Returns Performance Issues
Incident Report for cPaperless, LLC
Resolved
This incident has been resolved.
Posted Jan 11, 2021 - 09:03 CST
Update
We are continuing to monitor for any further issues.
Posted Jan 09, 2021 - 09:56 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 09, 2021 - 09:56 CST
Investigating
SafeSend Returns is having performance issues this morning, we are investigating and will update as soon as possible.
Posted Jan 08, 2021 - 11:56 CST
This incident affected: SafeSend Returns v4.0.