Issues Connecting to product Servers
Incident Report for cPaperless, LLC
Resolved
This incident has been resolved.
Posted 9 months ago. Jan 24, 2019 - 14:13 CST
Update
We are continuing to investigate this issue.
Posted 9 months ago. Jan 24, 2019 - 14:10 CST
Investigating
We are currently investigating this issue.
Posted 9 months ago. Jan 24, 2019 - 13:24 CST
This incident affected: SafeSend v6.2, SignatureFlow v5.7, and TicTie Calculate 4.5.