Tax Returns Stuck in "Preparing for Delivery"
Incident Report for SafeSend
Resolved
This issue has been resolved. You can now send returns without them getting stuck in preparing for delivery.

For returns that are already stuck, you must reupload, reprocess and deliver them again if you haven’t already. Returns stuck with the “Preparing for Delivery” status will have the option to delete after 24 hours since the initial attempt to send. Once the option appears, you may delete and you will not be charged for that return.
Posted Mar 27, 2020 - 08:18 MDT
Identified
The issue has been identified and a fix is in progress. This issue is sporadic and not affecting all returns.
Posted Mar 26, 2020 - 10:24 MDT
This incident affected: SafeSend Returns.