SafeSend DropOff files not being delivered
Incident Report for SafeSend
Resolved
This has been resolved. All DropOff files are being made available to their intended recipients.

Thank you for your continued support and patience.
Posted Nov 01, 2017 - 10:31 MDT
Identified
We have had multiple reports of files not being delivered to the intended recipient when the client sends through the DropOff feature of our system. Many of these reports are when clients try to upload Quickbooks files through the system, though it is not limited to only those file types. We have identified the issue and are currently working on a resolution and the reason why it is happening.

What we have confirmed, is that the files are being uploaded to our system and they are safe at rest. There is an issue in the system with making those files available for download to the SafeSend recipient. Once we have Identified exactly why this is happening or implemented a resolution, this page will be updated.

Thank you for your patience.
Posted Oct 12, 2017 - 17:13 MDT