SafeSend Returns Loading and Processing Issue
Incident Report for cPaperless, LLC
Resolved
Performance is back to normal. Due to the high amount of traffic this week, we'll monitor on a frequent basis.
Posted Oct 13, 2020 - 09:09 CDT
Update
We are continuing to monitor for any further issues.
Posted Oct 13, 2020 - 08:23 CDT
Monitoring
Performance has improved but we will continue to monitor on a regular basis.
Posted Oct 12, 2020 - 21:41 CDT
Investigating
SafeSend Returns is experiencing noticeable processing and loading issues, our engineering team is working on a resolution.
Posted Oct 12, 2020 - 15:32 CDT
This incident affected: SafeSend Returns v4.0.