SafeSend Returns Taxpayers experiencing errors while navigating their returns
Incident Report for cPaperless, LLC
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 09, 2019 - 14:04 CST
Investigating
We are currently investigating the reported issues and will provide an update to our status page shortly.
Posted 7 months ago. Feb 09, 2019 - 12:33 CST
This incident affected: SafeSend Returns v4.0.