SafeSend Exchange "The Link is Invalid"
Incident Report for SafeSend
Resolved
This incident has been resolved.
Posted Mar 25, 2022 - 18:05 MDT
Investigating
We are aware of issue that links sent through Exchange are showing "This link is Invalid." We are investigating and will provide more information when available.
Posted Mar 25, 2022 - 16:56 MDT
This incident affected: SafeSend Exchange (Legacy Version).