Uploading and Delivering Tax Return Issue
Incident Report for cPaperless, LLC
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 18, 2019 - 18:45 CDT
Investigating
We are currently experiencing issues uploading and delivering Tax Returns. We are investigating the issue and will provide an update shortly.
Posted 7 months ago. Mar 18, 2019 - 17:12 CDT
This incident affected: SafeSend Returns v4.0.