SSR Down
Incident Report for cPaperless, LLC
Resolved
This incident has been resolved.
Posted Oct 14, 2020 - 19:26 CDT
Update
We are continuing to investigate this issue.
Posted Oct 14, 2020 - 19:21 CDT
Investigating
Our SafeSend Returns system is currently down, we’re working to restore as soon as possible.
Posted Oct 14, 2020 - 19:21 CDT
This incident affected: SafeSend Returns v4.0.