SafeSend Returns Loading Issue
Incident Report for SafeSend
Resolved
This incident has been resolved.
Posted Mar 30, 2023 - 08:29 MDT
Investigating
Some users may be experiencing loading issues and error messages in SafeSend Returns. We are investigating the issue and will update you as soon as possible. In the meantime, you may want to try a different browser.
Posted Mar 30, 2023 - 07:43 MDT
This incident affected: SafeSend Returns.