Access Code Email Delivery

Incident Report for SafeSend

Resolved

This issue is now resolved. You may have received email notifications that delivery failed, but any new email deliveries will go through.
Posted Mar 10, 2026 - 09:07 MDT

Investigating

Clients are reporting that access codes are not being delivered to their email addresses. We are currently investigating this issue.
Posted Mar 10, 2026 - 07:59 MDT
This incident affected: Returns, Gather, Organizers, Extensions, and Exchange.