SafeSend Returns - Delivery Options
Incident Report for SafeSend
Resolved
This incident has been resolved. Please contact our Support team at support@safesend.com or 855-818-3552 if you have any follow-up questions. We apologize for the inconvenience.
Posted Sep 16, 2022 - 11:58 MDT
Identified
We are aware of an issue that causes the Delivery Options tab to not display or load for some customers. We are actively working to resolve this issue.

As a workaround, the firm can add a default Saved Message and Paper Filed Instructions message to correct this. Please see https://safesendreturns.zendesk.com/hc/en-us/articles/360011239114-Saved-Messages for more information.

Please contact our Support team at support@safesend.com or 855-818-3552 for additional assistance.
Posted Sep 16, 2022 - 08:58 MDT
This incident affected: SafeSend Returns.