SafeSend Returns - Delivery Options Page Blank
Incident Report for SafeSend
Resolved
This incident has been resolved. Please contact our Support team if you continue to experience issues. Thank you for your patience.

support@safesend.com
(855) 818-3552
Posted Jul 28, 2023 - 13:51 MDT
Identified
The issue has been identified and we are implementing a fix.
Posted Jul 28, 2023 - 13:07 MDT
Investigating
We are investigating reports of a blank page when accessing Delivery Options.
Posted Jul 28, 2023 - 10:20 MDT
This incident affected: SafeSend Returns.