Issues Accessing SafeSend Returns
Incident Report for cPaperless, LLC
Resolved
Services have been restored. Thank you for your patience.
Posted over 1 year ago. Mar 27, 2018 - 16:39 CDT
Investigating
We are currently experiencing intermittent issues accessing the SafeSend Returns website. We are investigating and will update this page when resolved.
Posted over 1 year ago. Mar 27, 2018 - 15:54 CDT