Issues accessing the SafeSend Suite
Incident Report for SafeSend
Resolved
This incident has been resolved. Thank you for your ongoing patience as we worked through impact of Microsoft Azure outage.
Posted Mar 20, 2024 - 14:15 MDT
Investigating
We are aware of and investigating issues related to accessing the SafeSend Suite.
Posted Mar 20, 2024 - 12:44 MDT
This incident affected: SafeSend Returns, SafeSend Organizers, SafeSend Extensions, and SafeSend Exchange (Suite Version).