Outlook Add-in Not Loading
Incident Report for SafeSend
Resolved
This issue has been resolved. Thank you for your patience.
Posted Mar 29, 2024 - 09:33 MDT
Investigating
We have received reports of the Outlook Add-in not loading. We are investigating.
Posted Mar 29, 2024 - 07:54 MDT
This incident affected: SafeSend Exchange (Suite Version).