Uploaded returns are not appearing in assignments
Incident Report for cPaperless, LLC
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 25, 2019 - 09:04 CDT
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jul 12, 2019 - 08:59 CDT
This incident affected: SafeSend Returns v4.0.