SafeSend outlook Plugin is Offline
Incident Report for cPaperless, LLC
Resolved
Thank you for your patience. The issues with the SafeSend Plugin have been resolved.
Posted over 1 year ago. Mar 12, 2018 - 09:13 CDT
Investigating
We are experiencing an issue with the Outlook plugin. When prompted to login, a message stating "Cannot connect to SafeSend server, will try and work offline" appears.

We are currently investigating this issue and will update this page with any new information. In the meantime, you can login at https://portal.safesend.com/login.aspx and send files from your online account.
Posted over 1 year ago. Mar 12, 2018 - 08:14 CDT