SafeSend Exchange Plug-In Issues
Incident Report for SafeSend
Resolved
The Plug-In inbox is now functioning as expected, please contact our support team at support@safesend.com with further questions or issues.
Posted Sep 16, 2021 - 08:35 MDT
Investigating
The SafeSend Exchange plug-in inbox is experiencing loading issues. Our development team is investigating and we'll update once information is available. In the interim, please use the portal for inbox access at https://portal.safesend.com/.
Posted Sep 13, 2021 - 08:33 MDT
This incident affected: SafeSend Exchange (Legacy Version).