SafeSend Returns - Issues loading reports
Incident Report for cPaperless, LLC
Resolved
I am pleased to report that this issue has been resolved. Please let us know if you have any continued issues with loading your reports.

We appreciate your patience in getting this resolved. We will continue to monitor throughout the day.
Posted over 1 year ago. Mar 29, 2018 - 09:07 CDT
Investigating
We are currently experiencing issues loading reports in SafeSend Returns. We are investigating and will update this page once resolved. Thank you.
Posted over 1 year ago. Mar 29, 2018 - 08:36 CDT