Email to "Please update your K1 Recipient Information"
Incident Report for SafeSend
Resolved
Please log into SafeSend Returns for more information about this situation. If you are already logged in, please log out and log back in. You will see a message with details regarding "Please update your K1 Recipient Information" Emails. We apologize for any inconvenience or confusion these reminder emails may have caused.
Posted Dec 27, 2022 - 10:26 MST
Investigating
We have received questions about emails related to updating K1 recipient information. These are legitimate emails related to built-in product functionality. While these are legitimate system emails, we did not intend for them to be sent on December 25. We are investigating further to correct the timing in the future. We apologize for the inconvenience.

A note about this feature. It is designed to ensure that the K1 recipients’ personal information is up to date. Please see our help center article for more information - https://safesendreturns.zendesk.com/hc/en-us/articles/1500007273301-K-1-Information-Update-Notifications
Posted Dec 26, 2022 - 14:35 MST
This incident affected: SafeSend Returns.