SafeSend Returns - Upload Issues
Incident Report for cPaperless, LLC
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 07, 2019 - 16:50 CDT
Monitoring
A fix has been implemented and we will continue to monitor over the weekend.
Posted about 2 months ago. Aug 02, 2019 - 16:38 CDT
Investigating
We are currently investigating this issue.
Posted about 2 months ago. Aug 02, 2019 - 10:43 CDT
This incident affected: SafeSend Returns v4.0.