SafeSend Plugin experiencing issues connecting to the server
Incident Report for cPaperless, LLC
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 08, 2019 - 10:45 CDT
Identified
SafeSend Plugin is experiencing issues connecting to the server. We have identified the issue and we are working on resolving it. The online SafeSend Portal is not affected by this issue.
Posted 4 months ago. Jul 08, 2019 - 07:55 CDT
This incident affected: SafeSend v6.2.