Logging into the SafeSend Suite
Incident Report for SafeSend
Resolved
We have received reports that users are now receiving codes. For details about the cause please visit https://status.twilio.com/.
Posted Mar 26, 2024 - 07:21 MDT
Investigating
We have received reports of users not being able to log into the SafeSend Suite because they are not receiving access codes. We are investigating.
Posted Mar 26, 2024 - 06:57 MDT
This incident affected: SafeSend Returns, SafeSend Organizers, SafeSend Extensions, and SafeSend Exchange (Suite Version).