SafeSend Returns - Upload Issues
Incident Report for cPaperless, LLC
Resolved
This incident has been resolved.
Posted about 2 months ago. Aug 01, 2019 - 16:12 CDT
Investigating
We are currently investigating this issue.
Posted about 2 months ago. Aug 01, 2019 - 15:08 CDT
This incident affected: SafeSend Returns v4.0.