Tic Tie & Calculate missing with new Adobe DC update
Incident Report for SafeSend
Resolved
Thank you for your patience while we worked with Adobe Acrobat to solve the problem of the missing TTC Toolbar. This issue has now been resolved. The below link has the the instructions on the resolution.

https://cpaperless.zendesk.com/hc/en-us/articles/115011878347

We appreciate your patience and support.
Posted Aug 28, 2017 - 08:58 MDT
Investigating
We have multiple reports of the Tic Tie & Calculate tools no longer being available in Acrobat DC. This is due to a change made to Acrobat in their latest update. We are currently working with Adobe to Identify and resolve the issue.

We will update this page when we have any additional information. We apologize for any inconvenience this may cause.
Posted Aug 11, 2017 - 09:29 MDT