SafeSend Returns Login Issues
Incident Report for cPaperless, LLC
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 28, 2018 - 11:01 CDT
Investigating
There are reports of some users receiving "Invalid Login when trying to login to SafeSend Returns. We are currently investigating this issue.
Posted about 1 year ago. Aug 28, 2018 - 09:03 CDT
This incident affected: SafeSend Returns v4.0.