SafeSend Returns Performance Issues
Incident Report for cPaperless, LLC
Resolved
This incident has been resolved.
Posted Oct 14, 2020 - 06:59 CDT
Monitoring
We've identified and implemented a fix for the e-sign and extended loading time errors. Fortunately, we were able to implement without any down time. The fix is effective immediately, feel free to resume activity at your earliest convenience.

We are grateful for your patience and understanding these last two days, our apologies to you and your customers.
Posted Oct 13, 2020 - 16:49 CDT
Identified
SafeSend Returns e-sign errors and extended loading times have been reported, we've identified an issue and the permanent fix will require us to suspend service for a period of time. Once that's been determined, we will notify all customers of the expected offline window.

We greatly appreciate your patience during this time and so close to the deadline. We'll provide further updates as they become available.
Posted Oct 13, 2020 - 13:23 CDT
This incident affected: SafeSend Returns v4.0.