SafeSend Outlook Plugin - Loading issues
Incident Report for cPaperless, LLC
Resolved
Services have been fully restored. Thank you for your patience. We apologize for any inconvenience this may have caused.
Posted over 1 year ago. Apr 16, 2018 - 12:37 CDT
Update
These Slow load times include SignatureFlow as well. We are still investigating the issue and will update when resolved.
Posted over 1 year ago. Apr 16, 2018 - 11:42 CDT
Investigating
We are currently experiencing slower than normal loading times for SafeSend. (not SSR)

We are investigating and will update this page when resolved.
Posted over 1 year ago. Apr 16, 2018 - 11:10 CDT