Users and clients are reporting they are not receiving access codes sent to their mobile devices.
Incident Report for SafeSend
Resolved
This incident has been resolved.
Posted Sep 28, 2023 - 14:40 MDT
Investigating
We have received reports that users and client are reporting they are not receiving access codes sent to their mobile devices. We are currently investigating
Posted Sep 28, 2023 - 14:13 MDT
This incident affected: SafeSend Returns, SafeSend Organizers, SafeSend Extensions, and SafeSend Exchange (Suite Version).