Service Interruption - SafeSend Tax Returns Loading/Errors for Client Experience and Client View

Incident Report for SafeSend

Update

This issue is now resolved.
Posted Mar 27, 2026 - 13:08 MDT

Investigating

We are aware of a service interruption affecting Tax Returns, are investigating the cause, and will provide updates as we learn more. 

Impact: Reduced functionality.

Workaround: Clear your cache/cookies, ensure your browser is up to date, or try a different browser if possible.

Thank you for your patience.
Posted Mar 27, 2026 - 10:33 MDT
This incident affects: Returns.