SafeSend Suite Login Issue
Incident Report for SafeSend
Resolved
This issue has been resolved.
Posted Nov 08, 2023 - 18:24 MST
Identified
Issues logging into the SafeSend Suite and/or errors when trying to deliver returns are related to a Microsoft Azure outage. Microsoft is actively working to fix the issue. We will update once fully operational.
Posted Nov 08, 2023 - 17:47 MST
Investigating
We have received reports of customers getting "Error Failed to update database SSR004491 because the database is read only" when attempting to log into the SafeSend Suite. We are investigating.
Posted Nov 08, 2023 - 17:06 MST
This incident affected: SafeSend Returns.