Safesend & Safesend Returns is currently experiencing issues
Incident Report for cPaperless, LLC
Resolved
This incident has been resolved.
Posted 6 months ago. May 02, 2019 - 16:11 CDT
Update
We are continuing to investigate this issue.
Posted 6 months ago. May 02, 2019 - 16:08 CDT
Update
We are continuing to investigate this issue.
Posted 6 months ago. May 02, 2019 - 15:38 CDT
Investigating
We are getting reports that customers are unable to sign into Safesend and Safesend Returns. We are working with our Development team to find the cause and resolve the issue.
Posted 6 months ago. May 02, 2019 - 15:37 CDT
This incident affected: SafeSend Returns v4.0 and SafeSend v6.2.