SafeSend Returns - Slow Upload to Ready
Incident Report for SafeSend
Resolved
This incident has been resolved.
Posted Jun 03, 2022 - 06:38 MDT
Investigating
We have received some reports of slowness when uploading returns and are investigating.
Posted Jun 02, 2022 - 15:00 MDT
This incident affected: SafeSend Returns.