SafeSend Exchange (Suite Version) - Application Not Loading
Incident Report for SafeSend
Resolved
This incident has been resolved.
Posted Nov 04, 2022 - 09:48 MDT
Investigating
We are experiencing a service incident with SafeSend Exchange not loading. The issue is being investigated and we will update once operational.
Posted Nov 04, 2022 - 09:08 MDT
This incident affected: SafeSend Exchange (Suite Version).